Note: You are viewing an old version of this page. View the current version.

Differences between version 4 and previous revision of KnowledgeBase/FreeBSD/BootStrap.

Other diffs: Previous Major Revision, Previous Author

Newer page: version 4 Last edited on Tuesday, 31 August 2010 1:41:37 by CyberLeo Revert
Older page: version 3 Last edited on Tuesday, 31 August 2010 1:38:26 by CyberLeo Revert
@@ -35,14 +35,29 @@
  
 /boot/boot.config 
 <code brush="bash"> 
 -h -S115200 
-/loader -h -S115200 # if /boot is its own partition 
+/loader -h -S115200 # if /boot is its own partition 
 </code> 
  
 /boot/loader.conf 
 <code brush="bash"> 
 console="comconsole,vidconsole" # or just comconsole, if there is no useful video hardware 
 comconsole_speed="115200" 
-boot_multicons="YES" # pass -D to kenv (boot -D)  
-boot_serial="YES" # pass -h to kenv (boot -h) 
+boot_multicons="YES" # pass -D to kenv (boot -D)  
+boot_serial="YES" # pass -h to kenv (boot -h) 
 </code> 
+  
+!!! System configuration  
+  
+/etc/fstab  
+* Pretty obvious  
+  
+/etc/rc.conf  
+<code brush="bash">  
+hostname="hostname.domain.tld"  
+ifconfig_<adapter>="<config>"  
+sshd_enable="YES" # Unless you really want a deaf box  
+zfs_enable="YES" # To auto-mount zfs filesystems; most useful when using ZFS root  
+</code>  
+  
+/etc/localtime  

version 4

Things to remember when bootstrapping a fresh install of FreeBSD outside of sysinstall

Boot Setup

Regular

/boot/loader.conf

loader_logo="beastie"
kernel="GENERIC"
opensolaris_load="YES" # if zfs root
zfs_load="YES"         # if zfs root

Tweaks if /boot is its own partition

# Boot scripts are hardcoded to look in /boot so make sure they can find everything
# Have to move the bootcode out of the way for this to work, though
cd /path/to/new/boot && mv boot boot.blk && ln -svf . boot

/boot/boot.config

/loader

/boot/loader.conf

vfs.root.mountfrom="ufs:/dev/ufs/root"
vfs.root.mountfrom="zfs:zpool/filesystem" # if zfs root

Tweaks if using serial console

/boot/boot.config

-h -S115200
/loader -h -S115200             # if /boot is its own partition

/boot/loader.conf

console="comconsole,vidconsole" # or just comconsole, if there is no useful video hardware
comconsole_speed="115200"
boot_multicons="YES"            # pass -D to kenv (boot -D)
boot_serial="YES"               # pass -h to kenv (boot -h)

System configuration

/etc/fstab

  • Pretty obvious

/etc/rc.conf

hostname="hostname.domain.tld"
ifconfig_<adapter>="<config>"
sshd_enable="YES" # Unless you really want a deaf box
zfs_enable="YES"  # To auto-mount zfs filesystems; most useful when using ZFS root

/etc/localtime