FindPage
View Source:
KnowledgeBase/FreeBSD/BootStrap
Note:
You are viewing an old version of this page.
View the current version.
Things to remember when bootstrapping a fresh install of FreeBSD outside of sysinstall !!! Boot Setup !! Regular /boot/loader.conf <code brush="bash" loader_logo="beastie" kernel="GENERIC" opensolaris_load="YES" # if zfs root zfs_load="YES" # if zfs root </code> !! Tweaks if /boot is its own partition <code brush="bash"> # Boot scripts are hardcoded to look in /boot so make sure they can find everything # Have to move the bootcode out of the way for this to work, though cd /path/to/new/boot && mv boot boot.blk && ln -svf . boot </code> /boot/boot.config <code brush="bash"> /loader </code> /boot/loader.conf <code brush="bash"> vfs.root.mountfrom="ufs:/dev/ufs/root" vfs.root.mountfrom="zfs:zpool/filesystem" # if zfs root </code> !! Tweaks if using serial console /boot/boot.config <code brush="bash"> -h -S115200 /loader -h -S115200 # if /boot is its own partition </code> /boot/loader.conf <code brush="bash"> console="comconsole,vidconsole" # or just comconsole, if there is no useful video hardware comconsole_speed="115200" boot_multicons="YES" # pass -D to kenv (boot -D) boot_serial="YES" # pass -h to kenv (boot -h) </code> !!! System configuration <small>Can usually be done after rebooting, with obvious accessibility exceptions</small> Root password * duh /etc/fstab * Pretty obvious /etc/rc.conf <code brush="bash"> hostname="hostname.domain.tld" ifconfig_<adapter>="<config>" sshd_enable="YES" # Unless you really want a deaf box zfs_enable="YES" # To auto-mount zfs filesystems; most useful when using ZFS root </code> /etc/ttys * Enable serial line, if using serial /etc/localtime * Link to or copy from the appropriate file in /usr/share/zoneinfo /etc/group <code brush="bash"> pw groupadd users -g 1000 </code> /etc/passwd <code brush="bash"> Coming soon </code> !!! Packages * sudo * bash