Differences between current version and predecessor to the previous major change of KnowledgeBase/FreeBSD/installworld.

Other diffs: Previous Revision, Previous Author

Newer page: version 3 Last edited on Sunday, 10 January 2010 13:19:49 by CyberLeo
Older page: version 2 Last edited on Monday, 2 June 2008 10:09:13 by CyberLeo Revert
@@ -1,5 +1,5 @@
-<verbatim
+<code brush=bash
 # Prepare disk 
 fdisk -B /dev/da0 
 bsdlabel -w -B /dev/da0s1 
 glabel label -v root /dev/da0s1a 
@@ -18,5 +18,5 @@
 # - Install all other ancillary scripts and files for a fully populated root 
 make DESTDIR=$DESTDIR distribution 
  
 # Configure /etc stuff in /mnt, then umount 
-</verbatim
+</code

current version

# Prepare disk
fdisk -B /dev/da0
bsdlabel -w -B /dev/da0s1
glabel label -v root /dev/da0s1a
newfs -U /dev/label/root
mount /dev/label/root /mnt

# Install
export DESTDIR=/mnt
cd /usr/src
# - Create the directory structure, lest everything else fail.
make DESTDIR=$DESTDIR distrib-dirs
# - Install the buildworld-compiled binaries
make DESTDIR=$DESTDIR installworld
# - Install the buildkernel-compiled kernel
make DESTDIR=$DESTDIR installkernel KERNCONF=STATUS
# - Install all other ancillary scripts and files for a fully populated root
make DESTDIR=$DESTDIR distribution

# Configure /etc stuff in /mnt, then umount